“Legacy” Bugs

One of the most maddening things about the Media Composer is that certain bugs never seem to get fixed. Regularly complained about, they’ve been in the software for so long they’re like old friends — or maybe enemies that never die. Avid could do a lot of good by dealing with some of these problems, and the bang-for-buck (editor satisfaction vs. engineering man hours) would probably be very high.

Here’s my list of favorites:

Slow Response When Opening or Creating a Bin
I’ve already mentioned this, but it bears repeating. Every time you open a bin or make a new bin the software runs a little routine that re-acquires every clip frame — from disk — in every open bin — even ones that are completely blocked behind other windows. This takes T I M E. And when you just want to quickly open a bin and check for something, this can drive you nuts. The software appears to be running the same routine that’s invoked every time you come back in from the Finder. It makes sense in that case because the MC needs to make sure no media has changed. But just to open a bin? Not necessary.

Source Timeline Glitches
When a clip is newly loaded into the source monitor and you hit “source timeline,” the timeline doesn’t center around the cursor. So you don’t know where you are. And the zoom factor always seems wrong. And then there’s the bug where you see the timeline for a completely different sequence until you cause a timeline redraw.

Rollers Jump to Next Cut
If you trim one element of an overlap cut to nothing, the roller will often disconcertingly jump to a nearby cut, screwing up your rhythm and forcing you to reset the trim.

Can’t Drag a Stereo Pair to the Next Track
Dragging stereo pairs vertically is perversely restricted. You can only move up or down two tracks at a time. I understand the logic for this circa 1993, but in 2008 does anybody need this?

Fades Don’t Work Properly Unless Cut Against Black
Fades are really dissolves to black. Cut a fade out of one clip against a fade in of another and try to trim the resulting transition. You can’t. Put a fade out on picture and sound at the end of your sequence using the “tail fade” button and you won’t be able to lengthen the end shot. (For more about fades see this post.)

Locators in Black
Never add a locator in black. If you do, you’ll corrupt that segment. (One symptom is that every time you move a segment adjacent to that black, you’ll create new, unnecessary, add-edits within it.)

Can’t Add Black at the End of a Sequence
How long do we have to work around this? It’s been there for 20 years.

Client Monitor Freezes in Trim Mode
If you’ve got rollers on both sides of a cut, and you’ve got dual image play turned on in trim settings (a great feature that FCP doesn’t have), your director is going to see a frozen frame while you look at a nicely moving image. This is an Adrenaline-only thing, but it’s been with us way too long.

That’s my short list. I’m sure you’ve got your own. Please add them in the comments.

Technorati Tags: , , ,

Advertisements
Explore posts in the same categories: Avid, Avid Wish List & Bugs

9 Comments on ““Legacy” Bugs”

  1. Adam Says:

    Slow Response When Opening or Creating a Bin – Is this not an OSX thing on Unity? I think part of it has to do with the way OSX interacts with the Unity. Like you say, every time you switch between another program and MC you get the pinwheel and a few second delay. It seems as though it’s checking to make sure nothing has changed on the mounted drives. I agree this is a bad way to operate but at the same time is it an OS level thing that couldn’t be avoided?

    My main gripe would be on Mac’s the File Count limits. I’m assuming MXF media has the same issues?

  2. Shane Ross Says:

    That slow bin opening has been around for a while….I do know that I had that same issue on OS9 Meridians. I hated to have multiple bins open at the same time because of that.

    And you STILL cannot add black to the tail? Man, that is just plain stupid. As is the ability to move stereo pair audio only two tracks at a time. When I get on FCP and can do this I feel so free, then back to an Avid and…GAH crap!

  3. David Wigram Says:

    The slow bin thing happens on Windows too. A right pain.

    I’ll add this one: accidentally resizing the tracks when messing with monitor buttons and track selectors. Why is that even possible without using a modifier key? Drives me nuts.

  4. Oren Says:

    And what about the 2GB file export limit? It’s like never ending 80s…
    And how about when you mark in Media Creation tool your desired media drives, just to discover that avid decided anyway to put your rendered and imported stuff into the system drive?

  5. Steve Says:

    I think the 2 Gig limit is not present when you capture to MXF. And in Adrenaline you can go beyond 2 Gigs with OMF media by selecting “capture to multiple files” in the capture settings.

    The wait for bins to open was not present in ABVB systems. It’s simply a mistake — not even a bug. There is no need to refresh all frameview clip icons in already opened bins when a new bin is opened. There’s no way they could change and they don’t need to be refreshed. I don’t see how this would have anything to do with what happens when you go to the Finder and then back to the MC — in that case the MC sensibly checks to make sure no media has changed. (But even in that case there is no need to recapture all those existing clip frames).

  6. Todd Smelser Says:

    We’ve got the Dual Roller Trim Freeze thing listed as a bug for the next release. Don’t know if it’ll get fixed yet though.

  7. Steve Says:

    Good news. Thanks for letting us know.

  8. Peter Says:

    The inability to insert from a sequence in the source monitor when any of your markers are on a transition effect drives me nuts. This is another one of those “Still? after 20 years?” flaws. Seems like it would be so trivial to fix.

  9. Steve Says:

    I completely agree. Maddening and easy to fix.

    S


Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: